Home Small Boat Forum

Welcome! Need support, you got it. Or share you ideas and experiences.

Re: The Next Hurdle in the old 15Hp Johnson saga

Well, I took the lower end of the 15 again, checked the impellor and it was fine, the pin has not sliped. wile I had it open I blew air through the pipe comming off the waterpump, throught the tattletale and through the return up inside the housing. Air flowed unrestricted, I attached a secondairy waterpump, and sent water through the system again at the waterpump feed.. Water is definitly circulating through the motor, but almost none is making the tatletale, I think it has something to do with the extention that was installed. In any event. I am now satisfied that the motor is being cooled, reguardless of the lack of water at the tatletale.
Tommorrow I plan on doing a little fiberglassing. I have a crack in each corner of the transom where it dips down. So I dremeled the cracks in order to stop them, tommorrow morning I will fiberglass the corners, and apply a layer of fiberglass both inside and outside to reinforce the motor mount area of the transom. Tommorrow afternoon I just might have to go for a ride in it. Depends on when I get up if Ill have enough time to let it cure.

The carberator still isnt functioning 100%, but it is running good enough that I want to take it out for a test run. ( saftey note, my 40 pound thrust electric, and my 6.5 gas will also be accompaning me on this test run.


This post is made possible by the generous support of people like you and our sponsors:
  K&K Audio / Lundahl Transformers   [ K&K Audio / Lundahl Transformers Forum ]


Follow Ups Full Thread
Follow Ups


You can not post to an archived thread.