Home Small Boat Forum

Welcome! Need support, you got it. Or share you ideas and experiences.

1969 Evinrude Fastwin 18 hp electric start outboard.

66.94.212.77

I am not one to beg for help, but my recently acquired vintage 18 hp, 1969 Evinrude Fastwin is challenging me. When I first took it out on its test run, I ran it about half throttle. It acted like it was hitting dead-heads and eventually popped a pin. After a number of attempts to resolve the problem, I found a used replacement lower unit ( with a prop ) for real cheap. After I put the new lower unit on and fabricated a handful of shere pins out of steel, I never shered another pin. Note: The replacement lower unit was off of a Johnson but it was an identical match to my Evinrude. My only problem is that since I replaced the lower unit there has been a marked reduction in accelleration and top-end speed. The engine is hanging off the back of a shallow hull 14' aluminum boat and used to keep up with a 50 hp Merc. Now it's really doggy. Could this speed reduction be due to an accidental oil/fuel mixture problem? I did have to replace a pin over about thirty feet of open, choppy water and could have upset the mixture settings. It's hard for me to experiment with the mixture setting because when I try to go to the back of the boat and attempt to steer off the tiller I almost do a boat wheely. I know it's not the prop, as both of my props are properly rated and undamaged. Any help or suggestions would be greatly appreciated. Thank you, one and all!!!


This post is made possible by the generous support of people like you and our sponsors:
  Parts Connexion  


Topic - 1969 Evinrude Fastwin 18 hp electric start outboard. - Ric 13:33:56 03/25/05 (2)


You can not post to an archived thread.